problema con winpic800

Seguir
hola a todos, recien estoy empesando a programar pic y ya me salta mi primer error, y no se por que es.
Yo estoy usando para programar el CCS , y para copilar winpic800 y el ic-prog, y uso el jdm. cuando paso el archivo. hex y lo verifico me salta: ERROR-> de verificacion 0x000000 y Verificado:0x3000 leido 0x0000, y me aparece lo mismo cuando lo quiero programar, yo pienso que es el programa de CCS, pero no se. quisiera saber por que y si alguien me puede ayudar me va hacer un favor grandisimo?

2 Soluciones propuestas

Ok.
Que micro estas usando?.-
En general esos errores se dan cuando esta mal configurado el hard y falla en la verificacion de lo que esta transfiriendo.
Subi tu circuito y descripcion del mismo como asi tambien el hex y lo simulamos y descartamos dudas de compilacion.-
Saludos.-
gracias mammuky por contestar, he estado vieno que cuando verifico el hard me aparece un error y me dice que el
hardware no responde, no se que puede ser?
Lo que podriamos hacer es q me digas como deberia configurar el sof para el JDM, si me haces el favor.
ahi te paso el programa en C, por que no me deja subir el hex, ni el esquematico
#include <16f84.h>
#fuses xt, nowdt
#use delay(clock=4000000)
#use standard_io(a)
#use standard_io(b)


void main()
{output_b(0);
port_b_pullups(true);
while(true){
if(input(pin_a0)==1)
{output_high(pin_b0);
delay_ms(100);
output_low(pin_b0);
output_high(pin_b1);
delay_ms(100);
output_low(pin_b1);
output_high(pin_b2);
delay_ms(100);
output_low(pin_b2);
output_high(pin_b3);
delay_ms(100);
output_low(pin_b3);
}
else
output_b(0);
}
}