problema con los .Net Frameworks

Seguir
Hola gente de YP, tengo este problema, acabo de reinstalar el W7 e instale todos mis programas que uso pero el problema es que ciertos programas necesitan los Framework 3 - 4.5 ya los descargue de la pagina official de Microsoft pero al instalarlos no hacen nada, descargue las versiones 3, 3.5, 4, 4.5 todas para W7 32 bits e intente instalar en orden pero nada, solo logro instalar correctamente el Net framework 4.0 pero necesito el 4.5.

Al tratar de instalar el framework 4.5 me dirigí al administrador de tarea y aparece el setup pero se ve en la pantalla, deje esperar por 30 min y nada, que sucede aqui?

1 Solución propuesta

Intenta instalar el excutable usando el privilegio de administrador es decir Ejecutar como administrador.